main =do
  x<-getLine
  y<-return x
  print $ stringToInt y

This is exactly equivalent to the other methods, but has the additional
'return', which is a no-op.  Please do not suggest such a style.  


Really?  Without the return it will not work. So, it isn't a noop.   Stylistically, I like it better than the 'let' in 'do' notation.