On Tue, May 20, 2014 at 7:58 PM, silvio <silvio.frischi@gmail.com> wrote:
I don't know how often i've seen this one
... >>= flip ...
when really we it should have been
... {...}

Your email is on the assertion-heavy side. Would you reconsider restating your case?

Just to take a small slice, instead of

> getExecutablePath = _NSGetExecutablePath >>= realpath

you'd prefer to use braces like this:

> getExecutablePath = _do realpath { _NSGetExecutablePath }

You could already write in today's haskell:

> getExecutablePath = realpath =<<  _NSGetExecutablePath

-- Kim-Ee