It still seems worthy to add the aliases for Data.Bifunctor.first and Data.Bifunctor.second. Hence:
import Control.Arrow
import Data.Bifunctor hiding (first, second)
and we don't need to have the methods qualified.
-----Original Message-----
From: "Eric Mertens"<emertens@gmail.com>
To: "Alexandre Rodrigues"<alexandrer_b@outlook.com >;
Cc: "박신환"<ndospark320@naver.com>; "Haskell Libraries"<libraries@haskell.org >;
Sent: 2018-05-09 (수) 01:04:12
Subject: Re: Resolve name collsion of `first` and `second` by Control.Arrow and Data.Bifunctor
I'm opposed to changing the names in either module. In modern code it should be fairly rare to import Control.Arrow. In the cases that both are needed qualified imports are available, and it wouldn't be worth breaking existing code by renaming the class methods of Bifunctor.
_______________________________________________
Libraries mailing list
Libraries@haskell.org
http://mail.haskell.org/cgi-bin/mailman/listinfo/libraries