On Thu, Apr 11, 2013 at 2:58 AM, Shachaf Ben-Kiki <shachaf@gmail.com> wrote:
Maybe it would be simpler to say:
signum x | x == 0 = x
| isNaN x = x
| x > 0 = 1
| otherwise = negate 1
Shachaf
Thanks Shachaf. This version is equivalent to the one I proposed, and it saves one test; so it's definitely preferable. I'll put this one in the ticket that'll finally be created for GHC.