+1, though, David has good points about unnecessary laziness. I'm fine with the name and the signature 

```
clamp :: Ord a ⇒ (a,a) → a → a
```

(or some variation on the theme). 


On Fri, Aug 14, 2020 at 5:38 PM, Sandy Maguire <sandy@sandymaguire.me> wrote:
Hi all,

It seems to me that base is missing the very standard function `clamp :: Ord a => a -> a -> a -> a`:

```haskell
clamp :: Ord a => a -> a -> a -> a
clamp low high = min high .max low
```

I propose it be added to Data.Ord. It's useful, generic, and non-trivial to get right (the "big" number goes with "min" -- causes me cognitive dissonance every time.)

Thanks,
Sandy

_______________________________________________
Libraries mailing list
Libraries@haskell.org
http://mail.haskell.org/cgi-bin/mailman/listinfo/libraries