New patches: [SshPrompt.hs (showXPrompt): use a single blank "Valery V. Vorotyntsev" **20071022192037 Delete trailing whitespace. Fix documentation typo. ] { hunk ./SshPrompt.hs 6 --- +-- hunk ./SshPrompt.hs 37 --- 3. In your keybindings add something like: +-- 2. In your keybindings add something like: hunk ./SshPrompt.hs 49 - showXPrompt Ssh = "SSH to: " + showXPrompt Ssh = "SSH to: " hunk ./SshPrompt.hs 60 -sshComplList = (nub . sort) `fmap` liftM2 (++) sshComplListLocal sshComplListGlobal +sshComplList = (nub . sort) `fmap` liftM2 (++) sshComplListLocal sshComplListGlobal hunk ./SshPrompt.hs 66 - + } Context: [Fix pragmas in XMonadContrib Shachaf Ben-Kiki **20071022011738] [introduce new combineTwo layout combinator. David Roundy **20071020191748 This layout combinator is similar in spirit (and in code) to the old combo combinator, but only allows two sublayouts. As a result, we don't need to wrap these in existentials, and reading works seamlessly. Also, we add the feature (which could also be added to combo) of being able to change which sublayout a given window is in through integration with WindowNavigation. I envision combo being deprecated soon. combineTwo isn't quite so flexible, but it's much easier and is better-coded also. ] [allow layout modifiers to modify a Message in transit. David Roundy **20071020191542 This is a helpful feature (for, e.g. WindowNavigation) that allows modifiers (if they so choose... the old API remains supported) to easily send a single Message to the modified layout in response to a Message. ] [XPrompt.hs (keyPressHandle): Ctrl-g and Ctrl-c added to quit keystrokes "Valery V. Vorotyntsev" **20071020170936 Obvious comments removed. ] [XPrompt.hs: trailing whitespace cleaned "Valery V. Vorotyntsev" **20071020170719] [test_XPrompt.hs: there is no ShellPrompt.rmPath "Valery V. Vorotyntsev" **20071019205830] [update UrgencyHook example config to reflect changes to WindowNavigation and core Config.hs Brent Yorgey **20071019145526] [add ToggleLayouts module. David Roundy **20071018214525] [default to empty description for layout modifiers. David Roundy **20071018202604 This is because modifierDescription is designed to be human-readable, and show rarely creates a human-readable description. And in many (if not most) cases, an empty description is precisely what we want. ] [beautify description code for empty modifier-description. David Roundy **20071018202438] [change definition of 'description' function for LayoutModifier so an extra space is not added if the modifier description is empty. Brent Yorgey **20071018183054] [-Wall police l.mai@web.de**20071018033000] [DynamicLog.hs: Add dzenColor Eric Mertens **20071018174523] [add function to rename workspaces. David Roundy **20071018145604] [fix WindowNavigation comment l.mai@web.de**20071018054315] [change example to dzenUrgencyHook Devin Mullins **20071018022026] [add dzenUrgencyHook as example (and the one I use) Devin Mullins **20071018021742] [fixed Dzen and gave it a configurable timeout Devin Mullins **20071018012910] [rename LayoutSelect & defaultLayout in comments Devin Mullins **20071016051819] [add import to comments, for clarity Devin Mullins **20071012044555] [documentation for UrgencyHook Devin Mullins **20071012034506] [d'oh, minor UrgencyHook cleanup Devin Mullins **20071012032558] [brand new UrgencyHook contrib, depends on X11-extras WMHints binding Devin Mullins **20071011051641 It's a LayoutModifier which lets you define an urgencyHook function -- the action gets performed wheneveran X client sends an XUrgencyHint message (i.e. tries to "flash" the "taskbar"). This statically points to Config.urgencyHook, which requires that the user add a line to Config.hs-boot, in addition to defining the urgencyHook. Documentation forthcoming. ] [TilePrime.hs: Give a description that distinguishs between horizontal/vertical Eric Mertens **20071018063749] [Truncate title at 80 characters Spencer Janssen **20071018003013] [shorten in sjanssenPP too Spencer Janssen **20071018002821] [Truncate long window titles Spencer Janssen **20071018002511] [DynamicLog.hs: Add ppWsSep field to PP to specify workspace separator. Eric Mertens **20071018001652 This can be useful when you are using colors to distinguish between workspaces and simply provides more functionality. The default behavior remains the same. ] [Wrapping the empty string yields the empty string Spencer Janssen **20071018001542] [DynamicLog: documentation only Spencer Janssen **20071017211427] [Allow the user to change the order of workspaces, layout, title Spencer Janssen **20071017211303] [Don't wrap the layout description by default Spencer Janssen **20071017211011] [DynamicLog: not . null. Duh. Spencer Janssen **20071017210912] [A big dynamicLog refactor Spencer Janssen **20071017210431 We introduce the PP type to allow user customization of dynamicLog. dynamicLogWithTitle has been eliminated because this is the default behavior for dynamicLog now. ] [Don't toLower the layout description. Spencer Janssen **20071017202953 If we'd really like lower case layout descriptions, the 'description' method in the LayoutClass instances should be changed instead. ] [TilePrime.hs: Correct behavior when number of windows <= nmaster Eric Mertens **20071017205153 Additionally this patch does various clean-ups that should not affect functionality. ] [Remove RunInXTerm in favor of Run Spencer Janssen **20071017202201] [Move runXXX functions to one module Christian Thiemann **20071012145233 This patch takes runProcessWithInput out of Dmenu, runProcessWithInputAndWait out of Dzen, and runInXTerm out of RunInXTerm and collects them in one central module called Run. This way, other modules may include Run instead of Dmenu to get what they want without giving the impression of making use of dmenu. ] [Fix LANGUAGE pragmas Shachaf Ben-Kiki **20071017194622] [use full screen for single window in TilePrime l.mai@web.de**20071017191421] [RotSlaves.hs: Add rotAll functions Eric Mertens **20071017173256] [TilePrime.hs: add usage info. Joachim Fasting **20071017192612] [TilePrime.hs: add LANGAUGE pragma. Joachim Fasting **20071017182042] [MetaModule.hs: add WorkspacePrompt. Joachim Fasting **20071017182027] [add TilePrime to MetaModule. David Roundy **20071017133202] [Initial import of TilePrime Eric Mertens **20071017052017 This layout provides a standard tiling layout with support for resize hints and filling the gaps created by them. ] [code cleanup in selectWorkspace. David Roundy **20071016231218] [allow users to go to dynamically-added workspaces with mod-n. David Roundy **20071016230301] [add modules to deal with Workspaces (select, etc) by name using XPrompt. David Roundy **20071016223347] [make windowNavigation simpler to use in simplest case. David Roundy **20071016214337] [compute nice window border for WindowNavigation properly. David Roundy **20071016213316] [fix docs on WindowNavigation. David Roundy **20071016210349] [compute a reasonable navigation color based on focussed color. David Roundy **20071015165504] [WindowNavigation: don't export the config constructor and some haddock fixes Andrea Rossato **20071013090524 I told to David I would have taken care of that: instead of exporting the config constructor we export 2 functions: navigateColor and noNavigateBorders. Updated documentation accordingly. ] [improvements in Combo. David Roundy **20071015132839] [TAG 0.4 Spencer Janssen **20071016212343] Patch bundle hash: 7c4d0d48afa5f9cae8e14d5ba090a3bfbd67236c