
New patches:

[Operation: coding style conformance
Andrea Rossato <andrea.rossato@unibz.it>**20070928112744] 
<
> {
hunk ./Operations.hs 123
     d <- asks display
 
     -- notify non visibility
-    let oldvistags = map (W.tag . W.workspace) $ W.current old : W.visible old
-        gottenHidden  = filter (\w -> elem w oldvistags) $ map W.tag $ W.hidden ws
-    sendMessageToWorkspaces Hide gottenHidden
+    let tags_oldvisible = map (W.tag . W.workspace) $ W.current old : W.visible old
+        gottenhidden    = filter (`elem` tags_oldvisible) $ map W.tag $ W.hidden ws
+    sendMessageToWorkspaces Hide gottenhidden
 
     -- for each workspace, layout the currently visible workspaces
     let allscreens     = W.screens ws
}

Context:

[SomeLayout: use the description of the wrapped layout
Spencer Janssen <sjanssen@cse.unl.edu>**20070928052344] 
[LayoutSelection: describe the active layout only
Spencer Janssen <sjanssen@cse.unl.edu>**20070928051858] 
[put transients completely on the screen when possible.
David Roundy <droundy@darcs.net>**20070927211014] 
[setLayout should not call sendMessage, because sendMessage calls windows
Spencer Janssen <sjanssen@cse.unl.edu>**20070928011510] 
[Add setLayout to the core
Spencer Janssen <sjanssen@cse.unl.edu>**20070928002241] 
[Document otherPossibleLayouts
Spencer Janssen <sjanssen@cse.unl.edu>**20070928000250] 
[Minor formatting
Spencer Janssen <sjanssen@cse.unl.edu>**20070928000025] 
[otherPossibleLayouts is empty by default
Spencer Janssen <sjanssen@cse.unl.edu>**20070927235845] 
[Update kind changes in the -class branch
Spencer Janssen <sjanssen@cse.unl.edu>**20070927222730] 
[Refactor floating code in manage
Spencer Janssen <sjanssen@cse.unl.edu>**20070927195534] 
[fix bug where ReleaseResources wasn't getting sent to all layouts.
David Roundy <droundy@darcs.net>**20070925215816] 
[Simplify readLayout, comment on surprising behavior
Spencer Janssen <sjanssen@cse.unl.edu>**20070925211708] 
[fix bug in reading of SomeLayouts.
David Roundy <droundy@darcs.net>**20070925202801] 
[add support for parseable layouts not in the default.
David Roundy <droundy@darcs.net>**20070925174134] 
[rename modifyLayout to handleMessage.
David Roundy <droundy@darcs.net>**20070925182906] 
[make it easier to define pure layouts.
David Roundy <droundy@darcs.net>**20070925170503] 
[Make a String description part of each Layout.
David Roundy <droundy@darcs.net>**20070924185753] 
[broadcast a ReleaseResources before restarting
Andrea Rossato <andrea.rossato@unibz.it>**20070924193915] 
[Added LayoutMessages
Andrea Rossato <andrea.rossato@unibz.it>**20070924193513
 This patch adds some more messages to manage layout: Hide is sent to
 layouts in that are not visible anymore. ReleaseReasourses is sent
 before a restart.
] 
[update screens for new kind of StackSet.
David Roundy <droundy@darcs.net>**20070924134545] 
[create default modifyLayout that ignores messages.
David Roundy <droundy@darcs.net>**20070923115219] 
[add layout selection back into core xmonad using LayoutSelection.
David Roundy <droundy@darcs.net>**20070921212159
 This is just a reimplementation of LayoutChoice.
] 
[make layouts preserved over restart
David Roundy <droundy@darcs.net>**20070921204316] 
[move Layout into StackSet.
David Roundy <droundy@darcs.net>**20070920221248
 WARNING! This changes the format of StackSet, and
 will definitely mess up your xmonad state, requiring
 at minimum a restart!
] 
[add (unused) Layout to StackSet.
David Roundy <droundy@darcs.net>**20070920212843] 
[remove unneeded Ord constraint.
David Roundy <droundy@darcs.net>**20070920210527] 
[eliminate a few Eq a constraints in StackSet.
David Roundy <droundy@darcs.net>**20070920210143] 
[Pointfree Mirror and SomeLayout instances
Spencer Janssen <sjanssen@cse.unl.edu>**20070920211042] 
[Use derived Show and Read instances for Mirror
Spencer Janssen <sjanssen@cse.unl.edu>**20070920205711] 
[define readLayout to create a SomeLayout based on a set of possible layout types.
David Roundy <droundy@darcs.net>**20070920181506] 
[add Read instance to Layout.
David Roundy <droundy@darcs.net>**20070920174529] 
[add Show instance to Layout
David Roundy <droundy@darcs.net>**20070920161208] 
[eliminate ugly OldLayout.
David Roundy <droundy@darcs.net>**20070920155237] 
[move Layout stuff into class (hokey first cut).
David Roundy <droundy@darcs.net>**20070914215959] 
[add prop for 'differentiate'
Don Stewart <dons@galois.com>**20070927231928] 
[document shiftWin
Karsten Schoelzel <kuser@gmx.de>**20070927134205] 
[new QC properties: floating a window is reversible, screens includes current screen
Don Stewart <dons@galois.com>**20070927220431] 
[Add 3 QC properties for focusMaster: local, idempotent, preserves invariant
Don Stewart <dons@galois.com>**20070927214401] 
[no regents in xmonad license
Don Stewart <dons@galois.com>**20070927214317] 
[note that we use pattern guards in the .cabal file
Don Stewart <dons@galois.com>**20070927214230] 
[Add StackSet.focusMaster (mod-m) to move focus to master
Don Stewart <dons@galois.com>**20070927213937] 
[use hPrint instead of hPutStrLn
Don Stewart <dons@galois.com>**20070927213901] 
[Split float up
Spencer Janssen <sjanssen@cse.unl.edu>**20070924090606] 
[Use the new StackSet.screens in windows
Spencer Janssen <sjanssen@cse.unl.edu>**20070924090523] 
[Add StackSet.screens
Spencer Janssen <sjanssen@cse.unl.edu>**20070924090425] 
[fmt, and tiny comment seeking clarification
Don Stewart <dons@galois.com>**20070917234658] 
[Eliminate Operations.sink too
Spencer Janssen <sjanssen@cse.unl.edu>**20070917214052] 
[Remove Operations functions which have StackSet equivalents, just use 'windows foo' instead
Spencer Janssen <sjanssen@cse.unl.edu>**20070917211953] 
[Change manpage token @@ to %! to avoid conflicts with Haddock (xmonad)
Alex Tarkovsky <alextarkovsky@gmail.com>**20070916235229] 
[Haddockify delete' comments
Spencer Janssen <sjanssen@cse.unl.edu>**20070917194114] 
[Fix float behaviour, add shiftWin.
Karsten Schoelzel <kuser@gmx.de>**20070910090329
 
 First, if float is called with window which is on a hidden workspace,
 then the window will remain on that hidden workspace.
 
 Now the focus should change more as expected:
 float w = (view current) . (shiftWin ws w)
     where
         current is the current screen/workspace
         shiftWin ws w is: - view the workspace w is on
             - set focus on w
             - shift ws
             - set focus back to window it was on that workspace
                 unless w was focused
 
 shiftWin was add to StackSet.hs 
] 
[Add delete' for use in shift
Karsten Schoelzel <kuser@gmx.de>**20070910113835
 
 Rename delete to delete' so we can clear floating status in delete,
 thus removing one special handling. 
 At the moment delete' is only used in shift, but is useful for temporarily
 removing a window from the stack.
] 
[update description field of cabal file
Don Stewart <dons@galois.com>**20070916023016] 
[pointfree looks nicer here
Don Stewart <dons@cse.unsw.edu.au>**20070911051928] 
[Remove redundant reveal
Spencer Janssen <sjanssen@cse.unl.edu>**20070910213807] 
[Add missing insert markers for generate-configs.sh in Config.hs
Alex Tarkovsky <alextarkovsky@gmail.com>**20070907120414] 
[Move lower boundary check into applySizeHints, because all users of applySizeHints
Karsten Schoelzel <kuser@gmx.de>**20070905192125
 do this manually.
] 
[export getAtom from XMonad.
Ivan Tarasov <Ivan.Tarasov@gmail.com>**20070825174156] 
[Use show rather than string hacks
Spencer Janssen <sjanssen@cse.unl.edu>**20070905202816] 
[switch WorkspaceId to String.
David Roundy <droundy@darcs.net>**20070820113658] 
[Alex Tarkovsky's docstring patch updated for conflicts
Spencer Janssen <sjanssen@cse.unl.edu>**20070905193558] 
[tasks done
Don Stewart <dons@cse.unsw.edu.au>**20070905004901] 
[TAG 0.3
Spencer Janssen <sjanssen@cse.unl.edu>**20070904195245] 
Patch bundle hash:
9d588d0f5d95e69691cedb8cc44ea33c15055094
