
Because confusing them is disastrous, so there is motivation to go to
extra lengths to keep them separate. I don't have particular thoughts
on whether that motivation is sufficient in this case.
On Thu, May 8, 2014 at 7:24 AM, Daniel Trstenjak
Hi Dan,
On Thu, May 08, 2014 at 11:58:28AM +0300, Dan Serban wrote:
newtype AskVolume = AskVolume Double deriving (Show) newtype AskPrice = AskPrice Double deriving (Show)
newtype BidVolume = BidVolume Double deriving (Show) newtype BidPrice = BidPrice Double deriving (Show)
I think that's a bit over the top, because why shouldn't prices and volumes be interchangeable between Asks and Bids?
Greetings, Daniel _______________________________________________ Beginners mailing list Beginners@haskell.org http://www.haskell.org/mailman/listinfo/beginners