patch applied (cabal): Using common function to name path environment variables in PathsModule and Test
Thu Jul 22 07:58:40 PDT 2010 Thomas Tuegel <ttuegel@gmail.com> * Using common function to name path environment variables in PathsModule and Test Ticket #215 (Overhaul support for packages' tests). The names of environment variables used to set package paths at runtime were previously hard-coded into the function that generates the paths module. A function generating the variable names is now exported from Distribution.Simple.Build.PathsModule and used to set the datadir in Distribution.Simple.Test to prevent breakage if the naming scheme changes. M ./Distribution/Simple/Build/PathsModule.hs -5 +15 M ./Distribution/Simple/Test.hs -6 +5 View patch online: http://darcs.haskell.org/cgi-bin/darcsweb.cgi?r=cabal;a=darcs_commitdiff;h=2...
participants (1)
-
Duncan Coutts