14 May
2001
14 May
'01
7:15 p.m.
So let's simply say: The contents of the include part of extent are implictly wrapped into double quotes iff they don't start with '<' or '"', and no ".h" is appended. Easy rule, doesn't mix concepts, and is readable:
foreign import ccall "static !myproc myinclude.h" myProc :: ...
I agree: don't make the '.h' implicit. To me it looks much more readable when it's obvious which is the cid and which is the include. Cheers, Simon
9294
Age (days ago)
9294
Last active (days ago)
0 comments
1 participants
participants (1)
-
Simon Marlow