Manuel I've just had cause to look at the FFI spec. Here's an idea. Since we have two productions, one for foreign import and one for foreign export, let's separate the productions for "entity" into "import_entity" and "export_entity". That way we don't have to say "entity" in *both* 4.1 and 4.2. Would that be OK? If so, would you like to action it. This is for clarity only -- no change to semantics. Simon
"Simon Peyton-Jones" <simonpj@microsoft.com> wrote,
Since we have two productions, one for foreign import and one for foreign export, let's separate the productions for "entity" into "import_entity" and "export_entity". That way we don't have to say "entity" in *both* 4.1 and 4.2.
Yes, I see your point. On the other hand, we'd have import_entity -> [String] export_entity -> [String] in the grammar in Section 3, then, and the introductory text to Section 4 would have to always mention both non-terminals. Nevertheless, I think, I tend to applying this change. Any other opinions? Cheers, Manuel
participants (2)
-
Manuel M. T. Chakravarty -
Simon Peyton-Jones