As Haskell finalizers need pre-emptive concurrency, maybe they should go somewhere related to concurrency. Or we could have a "Foreign.Concurrent".
Ok, how about Foreign.Concurrent.newForeignPtr and Foreign.Concurrent.addForeignPtrFinalizer? i.e. dodging the naming issue by using the module system. It also means that code which uses GHC's existing versions of these functions can be fixed by changing imports only. Cheers, Simon
"Simon Marlow" <simonmar@microsoft.com> wrote,
As Haskell finalizers need pre-emptive concurrency, maybe they should go somewhere related to concurrency. Or we could have a "Foreign.Concurrent".
Ok, how about Foreign.Concurrent.newForeignPtr and Foreign.Concurrent.addForeignPtrFinalizer? i.e. dodging the naming issue by using the module system. It also means that code which uses GHC's existing versions of these functions can be fixed by changing imports only.
Sounds good to me. Cheers, Manuel
participants (2)
-
Manuel M T Chakravarty -
Simon Marlow