
| avoid breaking existing programs. We might as well make named
| wildcards lexically scoped by default, not even opt-out (as was the
| case in my initial proposal).
I don't object strongly, so long as the user manual is very clear on the question, and mentions the inconsistency with ordinary type variables.
| About using a Maybe for sig_id to fix 10045: I tried it out, and your
| solution does indeed fix it. In order for TcSigInfo to still implement
| NamedThing, I used an 'Either Name TcId' instead of a 'Maybe TcId'. Do
| you prefer a separate data type for this instead of an Either? (Please
| come up with a good name for it in that case :)
Better:
* Remove instance NamedThing TcSigInfo
* Add a field sig_name :: Name, and use it instead of getName in tcTySigs
Comment that if sig_id = Just f, then sig_name = idName f
* Leave the sig_id field as (Maybe TcId). It needs a pretty big comment.
Actually sig_poly_id would be a better name for the field.
| Unfortunately, some of my tests started failing, so I'll post
| something on Phabricator as soon as I have worked out the kinks.
OK thank you. Ping me when ready
Simon
|
|
| Cheers,
| Thomas
|
|
|
| > Sorry to make such a misleading post.
| >
| > Simon
| >
| > | -----Original Message-----
| > | From: dominique.devriese@gmail.com
| > [mailto:dominique.devriese@gmail.com]
| > | On Behalf Of Dominique Devriese
| > | Sent: 05 February 2015 20:13
| > | To: Simon Peyton Jones
| > | Cc: Thomas Winant; ghc-devs@haskell.org; Frank Piessens
| > | Subject: Re: Partial type sigs
| > |
| > | Simon,
| > |
| > | 2015-02-05 17:44 GMT+01:00 Simon Peyton Jones
| >