Hi devs, Apologies if I'm missing context. Is it more better that "Unlifted" kind is other name, such as "BoxedUnlifted", "Bul", "%",... ? I'm studying Unlifted data types [1]. It's good proposals to optimize code by users. But I worry that newcomers may be confusing about its kind name. In my understanding [2], "unlifted" types may include "unboxed, unlifted" type. But "unlifted" kind does not include "unboxed, unlifted" types. [1]: https://ghc.haskell.org/trac/ghc/wiki/UnliftedDataTypes [2]: http://takenobu-hs.github.io/downloads/haskell_lazy_evaluation.pdf#page=190 (sorry, large) I wish you a happy new year. Regards, Takenobu 2015-09-04 17:03 GMT+09:00 Edward Z. Yang <ezyang@mit.edu>:
Hello friends,
After many discussions and beers at ICFP, I've written up my current best understanding of the unlifted data types proposal:
https://ghc.haskell.org/trac/ghc/wiki/UnliftedDataTypes
Many thanks to Richard, Iavor, Ryan, Simon, Duncan, George, Paul, Edward Kmett, and any others who I may have forgotten for crystallizing this proposal.
Cheers, Edward _______________________________________________ ghc-devs mailing list ghc-devs@haskell.org http://mail.haskell.org/cgi-bin/mailman/listinfo/ghc-devs