
30 Sep
2013
30 Sep
'13
5:22 a.m.
On 2013-09-30 04:00, Patrick Palka wrote:
+ isPrelude :: ImportDecl Name -> Bool + isPrelude = (== "Prelude") . moduleNameString . unLoc . ideclName
Can't you just do unLoc (ideclName imp) == pRELUDE_NAME here?
I think I hardcoded the name because I wanted to make sure not to run into the problem we've had before again, the "tryTc oddity": what happens when the Prelude isn't compiled yet and the typechecker refers to it? In case Prelude is handled specially here (i.e. pRELUDE_NAME always makes sense), your suggestion looks like it's a much better way of writing that definition. David/quchen