
Trac: https://ghc.haskell.org/trac/ghc/ticket/10843 I would like the following to be valid Haskell code: main = when True do putStrLn "Hello!" Instead of requiring a dollar sign before the "do". This would parse as main = when True (do putStrLn "Hello!") Has this been tried before? It seems fairly simple -- is there some complexity I'm missing? I've always been confused as to why the parser requires `$` there, and I've heard a lot of others ask about this as well. Perhaps we could fix that? PS. Regardless of whether this goes anywhere, it was fun to learn how to hack on GHC. It was surprisingly easy; I wrote up my experience here http://rawgit.com/gibiansky/4c54f767bf21a6954b23/raw/67c62c5555f40c6fb67b124.... The GHC wiki is outstanding; pretty much every intro question about ghc development I had was answered on a fairly easy-to-find wiki age. (Except for some stuff related to generating documentation and docbook, but whatever.)

Hi Andrew, thank you for the write-up. There are some good hints in there for how to make the documentation better. If you had used `BuildFlavour = stage2`, as the Newcomers page suggests, you'd have had some less trouble. I'll go and edit the HowtomakeGHCbuildquickly section, because it is outdated.
From the Newcomers page, it’s not quite clear exactly how to make it only build Stage 2, even though it suggests doing so.
The newcomers page says: - ## edit build.mk to remove the comment marker # on the line stage=2 - To speed up the development cycle, the final edit of build.mk makes sure that only the stage-2 compiler will be rebuild after this (see here about stages). Maybe you missed the comment about editing build.mk? Can you make suggestions how to make this more clear? I added some whitespace, but I'm not sure that's enough. Thanks, Thomas
_______________________________________________ ghc-devs mailing list ghc-devs@haskell.org http://mail.haskell.org/cgi-bin/mailman/listinfo/ghc-devs

Thomas,
Thanks for cleaning stuff up on the Newcomers page and others. I think all
the things that were somewhat confusing before are now much clearer and
less vague.
-- Andrew
On Sat, Sep 5, 2015 at 2:43 AM, Thomas Miedema
If you had used `BuildFlavour = stage2` as the Newcomers page suggests,
you'd have had some less trouble.
That should say `BuildFlavour = devel2`.
participants (2)
-
Andrew Gibiansky
-
Thomas Miedema