David Thanks for moving my early-inline patch series to HEAD. You'll remember that I pushed this patch (below) to spj-early-inline2 Can you be sure to cherry-pick this one too? It's important and I don't see it in HEAD yet. I'm surprised that there isn't a validate failure (T9505 if memory serves - see attached). Simon commit 002192aa8df463ae945e8a94147cfc1d848f43a5 Author: Simon Peyton Jones <simonpj@microsoft.com> Date: Fri Feb 24 16:55:36 2017 +0000 Fix a nasty bug in CoreSubst.collectBindersPushingCo The bug wsa in the use of (mkNthCo 0) to get the argument part of a function coercion. Not so! Now (->) takes four arguments so that 0 should have been 2. Enough with magic numbers. I defined decomposeFunCo, and used it throughout. Much nicer now; and correct. The nete effect, incidentally, was that T9509 was failing to specialise. (And that was the initial reason for introducing collectBindersPushingCo in the first place.)
On Wednesday, March 1, 2017 8:17:05 AM EST Simon Peyton Jones via ghc-devs wrote:
David Thanks for moving my early-inline patch series to HEAD. You'll remember that I pushed this patch (below) to spj-early-inline2 Can you be sure to cherry-pick this one too? It's important and I don't see it in HEAD yet. I'm surprised that there isn't a validate failure (T9505 if memory serves - see attached). Simon
It looks to me like these changes were included in one of Ben's patches. As far as I can tell, this is as you intend in HEAD. David
Ah yes. He combined it into commit 1990bb0df51250519b555ec271c693d289dd9802 Author: Simon Peyton Jones <simonpj@microsoft.com> Date: Tue Feb 28 12:11:33 2017 -0500 Make Specialise work with casts Thanks Simon | -----Original Message----- | From: David Feuer [mailto:david@well-typed.com] | Sent: 01 March 2017 13:49 | To: ghc-devs@haskell.org; Simon Peyton Jones <simonpj@microsoft.com> | Cc: David Feuer <david.feuer@gmail.com>; ben@well-typed.com | Subject: Re: collectBindersPushingCo | | On Wednesday, March 1, 2017 8:17:05 AM EST Simon Peyton Jones via ghc- | devs | wrote: | > David | > Thanks for moving my early-inline patch series to HEAD. | > You'll remember that I pushed this patch (below) to spj-early-inline2 | > Can you be sure to cherry-pick this one too? It's important and I | > don't see it in HEAD yet. I'm surprised that there isn't a validate | > failure (T9505 if memory serves - see attached). Simon | | It looks to me like these changes were included in one of Ben's patches. | As far as I can tell, this is as you intend in HEAD. | | David
participants (2)
-
David Feuer -
Simon Peyton Jones