#9616: Incorrect numbers from HpcMarkup.markup_plugin -------------------------------------+------------------------------------- Reporter: dfeuer | Owner: Type: bug | Status: closed Priority: normal | Milestone: Component: Code | Version: 7.9 Coverage | Keywords: Resolution: fixed | Architecture: Unknown/Multiple Operating System: | Difficulty: Easy (less than 1 Unknown/Multiple | hour) Type of failure: Incorrect | Blocked By: result at runtime | Related Tickets: Test Case: | Blocking: | Differential Revisions: Phab:D259 | -------------------------------------+------------------------------------- Comment (by Joachim Breitner <mail@…>): In [changeset:"9bf5228fdc1937f44901a945553eea3cb0f14faa/ghc"]: {{{ #!CommitTicketReference repository="ghc" revision="9bf5228fdc1937f44901a945553eea3cb0f14faa" Use dropWhileEndLE p instead of reverse . dropWhile p . reverse Summary: Using `dropWhileEndLE` tends to be faster and easier to read than the `reverse . dropWhile p . reverse` idiom. This also cleans up some other, nearby, messes. Fix #9616 (incorrect number formatting potentially leading to incorrect numbers in output). Test Plan: Run validate Reviewers: thomie, rwbarton, nomeata, austin Reviewed By: nomeata, austin Subscribers: simonmar, ezyang, carter, thomie Projects: #ghc Differential Revision: https://phabricator.haskell.org/D259 GHC Trac Issues: #9623, #9616 Conflicts: compiler/basicTypes/OccName.lhs }}} -- Ticket URL: <http://ghc.haskell.org/trac/ghc/ticket/9616#comment:6> GHC <http://www.haskell.org/ghc/> The Glasgow Haskell Compiler