
#13145: Documentation shouldn't call things functions that aren't functions -------------------------------------+------------------------------------- Reporter: chris-martin | Owner: Type: bug | Status: new Priority: normal | Milestone: Component: libraries/base | Version: 8.0.1 Resolution: | Keywords: Operating System: Unknown/Multiple | Architecture: Type of failure: Documentation | Unknown/Multiple bug | Test Case: Blocked By: | Blocking: Related Tickets: | Differential Rev(s): Wiki Page: | -------------------------------------+------------------------------------- Description changed by chris-martin: @@ -13,0 +13,3 @@ + In that case, I suggest we rename the sections "Input functions" and + "Output functions" to simply "Input" and "Output". + New description: For example, in the [https://hackage.haskell.org/package/base-4.9.0.0/docs/Prelude.html Prelude] docs we have a section called "Input functions" in which only one of the four values is a function: {{{ getChar :: IO Char getLine :: IO String getContents :: IO String interact :: (String -> String) -> IO () }}} In that case, I suggest we rename the sections "Input functions" and "Output functions" to simply "Input" and "Output". Referring to non-function values (particularly of type `IO`) as "functions" is often a sign that beginners haven't fully grasped some concepts about purity, so I think it's important to clean up our own language. -- -- Ticket URL: http://ghc.haskell.org/trac/ghc/ticket/13145#comment:2 GHC http://www.haskell.org/ghc/ The Glasgow Haskell Compiler