
waitUntil sounds like a plausible name. Better than itsAfter or timeAfter. But perhaps sleepUntil would be better, because it's a variant of sleep? Simon | -----Original Message----- | From: glasgow-haskell-users-bounces@haskell.org [mailto:glasgow-haskell-users- | bounces@haskell.org] On Behalf Of Tomasz Zielonka | Sent: 19 December 2005 09:28 | To: GHC-users | Subject: [STM] Better name for waitUntil? | | Hello! | | I am finishing my waitUntil implementation for STM. It's a new | STM action that will allow to wait for a given time point. | | waitUntil :: UTCTime -> STM () | | (UTCTime is from Ashley Yakeley's Time library.) | | The intended semantics is that | | waitUntil t | | will succeed as soon as time passes t, or more precisely when (now >= t). | | Right now I am to find a better name for waitUntil. Maybe it should be | more declarative, like "itsAfter" or "timeAfter"? I am not a native english | speaker, so I am probably missing many options. Any ideas? | | I also think about adding something like "itsBefore", which would mean | (now < t). | | How about "it'sAfter" ? | Maybe only "after", without "it's" ? | | Thanks in advance for your help. | | PS. I imagine that it would be possible to implement waitUntil more | efficiently in GHC's RTS, but my implementation can be a nice | showcase for STM's expressivity, and it's still quite efficient | (I used some (quite elegant :) hacks to implement subsecond | precision waitUntil efficiently). | | Best regards | Tomasz | | -- | I am searching for a programmer who is good at least in some of | [Haskell, ML, C++, Linux, FreeBSD, math] for work in Warsaw, Poland | _______________________________________________ | Glasgow-haskell-users mailing list | Glasgow-haskell-users@haskell.org | http://www.haskell.org/mailman/listinfo/glasgow-haskell-users