mån 2004-06-28 klockan 14.00 skrev Peter Simons:
Simon Marlow writes:
I'm tempted to replace the current setSocketOption with this version. Would anyone object?
On the contrary. IMHO, the SockOption type should be extended to contain the required parameter, for example:
data SocketOption = Debug Bool | ReuseAddr Bool | SendBuffer (Maybe Int) -- bytes | RecvTimeOut (Maybe Int) -- milliseconds | SendTimeOut (Maybe Int) | [...]
Then setSocketOption would even add the type-safety which the original function call doesn't have, and it would be more intuitive to use.
Wouldn't that make getSocketOption :: Socket -> SocketOption -> IO Int a bit strange? How would you propose to change it? /Martin -- Martin Sjögren <md9ms@mdstud.chalmers.se>