
Python: note1.time() cursor1.time() staff1.time()
(...)
So I'm thinking of moving to a scheme in Haskell using modules, most types being defined in their own modules, and doing qualified imports. Generic names like 'time' can be defined in each module w/o clashing.
(...)
I would be interested in comments... is this a good way to do things? Am I trying too hard to impose OO on Haskell and is there a better way?
I had this same experience. After you learn how to think in Haskell, the problem will just disapear. Maybe it would help you more if, instead of just this small detail, you write the general idea of what you want your application to do. Then we could sugest you a Haskell-like design where you would not need note1.time, cursor.time etc. In time you'll probably want to study this: http://hackage.haskell.org/package/haskore Best, Maurício