26 Jul
2010
26 Jul
'10
8:53 p.m.
That's just cool. I now reverse my original statement - 'flip' does have it's place in the pantheon of standard Haskell functions. -deech On Mon, Jul 26, 2010 at 3:42 PM, Nils <ml@n-sch.de> wrote:
On 26.07.2010 08:33, David Virebayre wrote:
listeEtagTot = concatMap (`listeEtagArm` cfgTypesTringle) listeArmOrd
You can use flip as a "wildcard" aswell:
listeEtagTot = concatMap (listeEtagArm `flip` cfgTypesTringle) listeArmOrd
Makes it even more readable in my opinion, since this really "shows" you where the value belongs to.
_______________________________________________ Haskell-Cafe mailing list Haskell-Cafe@haskell.org http://www.haskell.org/mailman/listinfo/haskell-cafe