
5 Aug
2013
5 Aug
'13
4:29 p.m.
Oh, a new testing framework - I'm always interested in that :)
At the very least, you'll have to change module names (Test.Framework -> Test.Tasty, Test.Framework.Providers.HUnit -> Test.Tasty.HUnit, ...), and wrap the top-level list of tests into a testGroup.
If you have type signatures, you'll need to rename Test to TestTree.
That should be enough in most cases. If you use plusTestOptions, you'll need to look up appropriate functions from Test.Tasty.Options. Making a tutorial would probably be a good idea here.
Janek