30 May
2002
30 May
'02
8:10 a.m.
| It would be strange to name a function readFloat if its type is | RealFrac a => ReadS a. | I think the function should be named readFrac. For | compatibility, one could put the following into the prelude: | readFloat :: RealFloat a => ReadS a | readFloat = readFrac Well, that would be possible, but there are other naming inconsistencies in the Prelude; indeed, even in the numeric library. My inclination is to put up with the inconsistency. You have to look up the type to use it anyhow. Simon
8856
Age (days ago)
8856
Last active (days ago)
0 comments
1 participants
participants (1)
-
Simon Peyton-Jones