
Greetings! The second release candidate for Edison 1.2 is now ready for comments. The notable changes from RC1 are: * add strict variants of all folds and reduces * reverse argument orders to 'rcons' and 'lookup*' in Sequence * Add symbolic operators for lcons, rcons, append, and lookup from the Sequence API * Add symbolic operators for subsetEq, difference, intersection and union from the set API * rename 'single' to 'singleton' in all APIs * rename 'intersect' to 'intersection' in Collection and Associated Collection APIs * add 'adjustOrInsert' to the Associated Collection API (see http://www.haskell.org//pipermail/libraries/2006-February/ 004952.html for a use case) And the following are the remaining major issues I'd like to get feedback about: -- Edison defines 'subset' and 'subsetEq' in the set API. Data.Set has operations with the same meanings named 'isProperSubsetOf' and 'isSubsetOf'. I am considering adoping the Data.Set names, but they are quite a bit longer. Also what about the meaning of "subset" vs "proper subset"? What do you find most intuitive? -- Data.Map defines 'isSubmapOfBy' and 'isProperSubmapBy'. Edison has no corresponding API methods. Are they important enough to add? -- What do you think about the symbolic operators? Is the fact that (++) clashes with the Prelude a problem? Should the operators be folded into the "Data.Edison" module instead? (see http://www.eecs.tufts.edu/~rdocki01/docs/edison/Data-Edison- Sym.html) In addition, I'm interested in any API related feedback you might have. Code and docs can be found at the project website: http://www.eecs.tufts.edu/~rdocki01/edison.html Or you can go directly to the haddock docs: http://www.eecs.tufts.edu/~rdocki01/docs/edison/index.html Or the darcs repo: http://www.eecs.tufts.edu/~rdocki01/edison/ Thanks, Rob Dockins Speak softly and drive a Sherman tank. Laugh hard; it's a long way to the bank. -- TMBG