
11 Feb
2005
11 Feb
'05
3:26 a.m.
In article <5.1.0.14.2.20050210150449.0208fd50@127.0.0.1>,
Graham Klyne
Hmmm... I would be inclined to separate basic calendrical calulations from timezones (as opposed to timezone offsets). Prior to RFC3339, work in this area was bogged down in the comlexities of timezones... it was by separating them that we were able to come to consensus on the basics required for timestamping.
The most obvious functions in Calendar are going to be these: utcToCalendar :: TimeZone -> UTCTime -> CalendarTime calendarToUTC :: TimeZone -> CalendarTime -> UTCTime But by TimeZone I mean a fixed offset to UTC, so perhaps TimeOffset is a better name. -- Ashley Yakeley, Seattle WA