There is some precedent for 'sortOn' as the naming convention should we choose to go ahead with it. http://lukepalmer.wordpress.com/2009/07/01/on-the-by-functions/ Having some mechanism by which we can explicitly request the Schwartzian transform like that as opposed to 'element by element' By functions strikes me personally as a good idea and sufficiently non-trivial to pass the "Fairbairn threshold" in my book. +1 from me. -Edward On Sun, Apr 6, 2014 at 4:34 PM, <johnw@newartisans.com> wrote:
Niklas Haas <haskell@nand.wakku.to> writes:
Oh yes, 'sortOn' is a really nice name. :)
Huh, that name just reminded me of GHC.Exts.sortWith:
Either of the names sortOn, or sortWith, sound good. I think I prefer sortWith.
John _______________________________________________ Libraries mailing list Libraries@haskell.org http://www.haskell.org/mailman/listinfo/libraries