
I am happy to see that in GHC 6.3 that HUnit is included with GHC using "-package HUnit-1.0." However, the name "HUnit-1.0" is very confusing because it is different from the previous "HUnit 1.0." In particular, the HUnit package is now "Test.HUnit" and not just "HUnit." Therefore, I think it would be better to name the package something other than "HUnit-1.0," perhaps "HUnit-1.1." Otherwise, it seems like people could be confused by the fact that the existing documentation about HUnit on the Internet for HUnit 1.0 does not match the code for this "new" HUnit 1.0. Naming the package "HUnit-1.1" would allow somebody to create a "HUnit-1.0" package that is compatible with the "HUnit 1.0" that is documented on the HUnit Sourceforge website [1]. Or, somebody could create a "HUnit-1.1" package for GHC 6.2.2 that is equivalent to the Cabal package. Note that I have already created a HUnit-1.0 package for GHC 6.2.2 that uses the source code from the Sourceforge site. Alternatively, could you supply a module "HUnit" inside package "HUnit-1.0" that simply exports everything from Test.HUnit, with everything marked deprecated and with a pointer to use Test.HUnit instead? Basically, I am just trying to ensure that my code that uses HUnit will compile with both GHC 6.2.2 and GHC 6.3/GHC 6.4, without using the preprocessor. Thanks, Brian [1] http://hunit.sourceforge.net/HUnit-1.0/Guide.html