11 Nov
2006
11 Nov
'06
6:43 a.m.
On 11/10/06, Ashley Yakeley <ashley@semantic.org> wrote:
kahl@cas.mcmaster.ca wrote:
I'd much prefer Data.Unsafe.
I'd like to see all unsafe function in an Unsafe.* hierarchy (possibly consisting only of the single module Unsafe). Thus one could avoid unsafety altogether by avoiding the Unsafe and Foreign hierarchies.
Couldn't you just avoid using functions having "unsafe" as a name prefix? Its not like they have names like "inocuousPerformIO" or anything!