
+1 to `zeroBits`. The name fits in with `setBit` etc. I'm also okay with the name `zero`. Twan On 16/02/14 17:45, Edward Kmett wrote:
`bitZero` sounds like it should equal `bit 0`, which it doesn't.
zeroBits ?
-Edward
On Sun, Feb 16, 2014 at 11:42 AM, Herbert Valerio Riedel
mailto:hvr@gnu.org> wrote: Hi,
On 2014-02-16 at 15:10:42 +0100, ARJANEN Loïc Jean David wrote: > I'll have to come down against that proposal because, at least on amd64 for 64 > bits-sized types (Int, Int64, Word & Word64), it doesn't works.
You're right, I don't know how I could have missed that :-/
Since the presumed pre-condition for the proposal (that 'bit (-1) == 0' would already hold) I hereby amend the proposal to
> Introduce a new class method > > class Bits a where > ... > -- | Value with all bits cleared > bitZero :: a > ... > > modulo naming of 'bitZero'
(I'm hesitant to consume "zero" from the namespace as was suggested by Henning) _______________________________________________ Libraries mailing list Libraries@haskell.org mailto:Libraries@haskell.org http://www.haskell.org/mailman/listinfo/libraries
_______________________________________________ Libraries mailing list Libraries@haskell.org http://www.haskell.org/mailman/listinfo/libraries