19 Nov
2014
19 Nov
'14
5:26 a.m.
Hi, On 18 November 2014 16:38, Andres Löh <andres.loeh@gmail.com> wrote:
FWIW, I'm in favour of:
* not putting this into Data.Word, but rather into Data.Nat or Data.Natural * having default subtraction to be saturated rather than partial * adding a Nat type for bounded naturals as well (even if it's just a synonym for Word)
+1 on all points. 'Data.Nat.Nat' will clash with 'data Nat = Z | S Nat' (which is quite popular), but I think that it's better to call that 'Peano' or something similar. Perhaps we could add 'Peano' to Data.Nat while we're at it?