
Hi Karsten, this solution is much more elegant, nice :) If you agree, I will add both functions to RotSlaves.hs, rename them to rotSlavesUp and rotSlavesDown respectively and add you to the list of authors (and maintainers?). Greetings Hans Philipp
I think I have a version which is easier to understand (at least for me):
rotSlaves' s@(SS.Stack _ [] []) = s rotSlaves' (SS.Stack t [] (r:rs)) = SS.Stack t [] (rs ++ [r]) --Master has focus rotSlaves' (SS.Stack t ls rs) = SS.Stack t' (reverse (master:revls')) rs' --otherwise where (master:q:revls') = reverse (t:ls) (t':rs') = (rs ++ [q])
Actually it rotates the slaves into the other direction (which made it simpler), but that shouldn't matter much when using the TwoPane layout.
I hope someone else will find that usefull...
Hans Philipp Annen
Karsten Schölzel -- Karsten Schölzel | Email: kuser@gmx.de Friedrichstraße 7 | Jabber: topox@jabber.ccc.de 18057 Rostock | VoIP: sip:5857712@sipgate.de Germany | sip:708529@fwd.pulver.com | Tel: +4918015855857712 | Mobile: +491627144185