Mon Jan 18 11:20:58 EST 2010 Adam Vogt
* Correct warnings with ghc-6.12
Changes include:
- compatibility with base-4 or 3 (base-2 untested) by using
extensible-exceptions. This adds an additional dependency for users of
ghc<6.10)
- list all dependencies again when -ftesting (change in Cabal-1.8.0.2)
- remove unnecessary imports
- suppress -fwarn-unused-do-bind, with appropriate Cabal-1.8 workaround,
described here:
http://www.haskell.org/pipermail/xmonad/2010-January/009554.html
Mon Jan 18 11:22:56 EST 2010 Adam Vogt
* Rename numlockMask to numberlockMask to help users of the template config.
Without the change, the errors are like:
[ unrelated error messages ]
No constructor has all these fields: `numlockMask',
`terminal', [every other field set]
With the change:
`numlockMask' is not a record selector
[ context where numlockMask is named ]