6 Jan
2001
6 Jan
'01
9:50 p.m.
Marcin 'Qrczak' Kowalczyk wrote:
[...] I think the conversion story should proceed thus: - For now the implementation will not do any conversion.
... and simply throws away the upper half / fills it with zero.
[...] We can't have separate mallocCString and pokeCString after the conversion switch, because the size depends on the contents, because a conversion can change the length. So we should not provide them now either.
I don't get your point here completely, but I believe Mr. CharConv here... :-)
[...] Let me repeat a proposal of two functions for MarshalUtils (better names are welcome): [...]
I have something similar in HOpenGL for argc/argv handling, so this is probably a good idea (modulo some renaming?). Cheers, Sven