That doesn't seem to be saying anything motivating the choice of name, just motivates the existence of some nullary unboxed type. -Edward On Tue, Dec 17, 2013 at 2:45 PM, Roman Cheplyaka <roma@ro-che.info> wrote:
Have you read the Note [Nullary unboxed tuple] in compiler/types/Type.lhs? I think it addresses this, although I'm not going to pretend I understand what's going on there.
Roman
* Krzysztof Gogolewski <krz.gogolewski@gmail.com> [2013-12-17 19:28:14+0100]
Hello,
Small bikeshedding: I propose to rename recently added Void# (in GHC.Prim) to Unit#, and void# to unit#. As far as I understand, this type is the unboxed equivalent of () (i.e. single-element type) rather than Void (i.e. empty type). The name Void# might be reserved for a type which has completely no inhabitants. Any comments?
KG
_______________________________________________ ghc-devs mailing list ghc-devs@haskell.org http://www.haskell.org/mailman/listinfo/ghc-devs
_______________________________________________ ghc-devs mailing list ghc-devs@haskell.org http://www.haskell.org/mailman/listinfo/ghc-devs