#2301: Proper handling of SIGINT/SIGQUIT -------------------------------------+------------------------------------- Reporter: duncan | Owner: Type: bug | Status: patch Priority: high | Milestone: 7.8.1 Component: | Version: 6.12.3 libraries/process | Keywords: Resolution: | Architecture: Unknown/Multiple Operating System: POSIX | Difficulty: Unknown Type of failure: Incorrect result | Blocked By: at runtime | Related Tickets: Test Case: | #3994,#5766,#7229,#4274,#3318,#1619 Blocking: | -------------------------------------+------------------------------------- Comment (by Herbert Valerio Riedel <hvr@…>): In [changeset:"3d8f9bb7f84c1fbb5efa62dd46daae44110ddb18/process"]: {{{ #!CommitTicketReference repository="process" revision="3d8f9bb7f84c1fbb5efa62dd46daae44110ddb18" Rename runGenProcess_ and leave a deprecated stub At least Cabal was using runGenProcess_, and the previous patches addressing #2301 changed its type already. So this adds a deprecated stub with the original type and the real function gets to have a less odd name. Authored-by: Duncan Coutts <duncan@well-typed.com> Signed-off-by: Herbert Valerio Riedel <hvr@gnu.org> }}} -- Ticket URL: <http://ghc.haskell.org/trac/ghc/ticket/2301#comment:41> GHC <http://www.haskell.org/ghc/> The Glasgow Haskell Compiler