[GHC] #15017: Come up with a better name for `tcExtendTyVarEnv2`
#15017: Come up with a better name for `tcExtendTyVarEnv2` -------------------------------------+------------------------------------- Reporter: mpickering | Owner: (none) Type: task | Status: new Priority: normal | Milestone: 8.4.3 Component: Compiler | Version: 8.2.2 Keywords: | Operating System: Unknown/Multiple Architecture: | Type of failure: None/Unknown Unknown/Multiple | Test Case: | Blocked By: Blocking: | Related Tickets: Differential Rev(s): | Wiki Page: -------------------------------------+------------------------------------- It must be different somehow from `tcExtendTyVarEnv` but without reading the source code, it's hard to tell what the difference is. -- Ticket URL: <http://ghc.haskell.org/trac/ghc/ticket/15017> GHC <http://www.haskell.org/ghc/> The Glasgow Haskell Compiler
#15017: Come up with a better name for `tcExtendTyVarEnv2` -------------------------------------+------------------------------------- Reporter: mpickering | Owner: (none) Type: task | Status: new Priority: normal | Milestone: 8.4.3 Component: Compiler | Version: 8.2.2 Resolution: | Keywords: Operating System: Unknown/Multiple | Architecture: | Unknown/Multiple Type of failure: None/Unknown | Test Case: Blocked By: | Blocking: Related Tickets: | Differential Rev(s): Wiki Page: | -------------------------------------+------------------------------------- Comment (by sighingnow): Also `scopeTyVars2`. What about to rename `scopeTyVars2` to `scopeTyVarsWithName` and `tcExtendTyVarEnv2` to `tcExtendTyVarEnvWithName` ? -- Ticket URL: <http://ghc.haskell.org/trac/ghc/ticket/15017#comment:1> GHC <http://www.haskell.org/ghc/> The Glasgow Haskell Compiler
#15017: Come up with a better name for `tcExtendTyVarEnv2` -------------------------------------+------------------------------------- Reporter: mpickering | Owner: (none) Type: task | Status: new Priority: normal | Milestone: 8.4.3 Component: Compiler | Version: 8.2.2 Resolution: | Keywords: Operating System: Unknown/Multiple | Architecture: | Unknown/Multiple Type of failure: None/Unknown | Test Case: Blocked By: | Blocking: Related Tickets: | Differential Rev(s): Wiki Page: | -------------------------------------+------------------------------------- Comment (by simonpj): Of `tcExtendTyVarEnvByName`? The comments on the definition could make it clear. -- Ticket URL: <http://ghc.haskell.org/trac/ghc/ticket/15017#comment:2> GHC <http://www.haskell.org/ghc/> The Glasgow Haskell Compiler
#15017: Come up with a better name for `tcExtendTyVarEnv2` -------------------------------------+------------------------------------- Reporter: mpickering | Owner: (none) Type: task | Status: new Priority: normal | Milestone: 8.4.3 Component: Compiler | Version: 8.2.2 Resolution: | Keywords: Operating System: Unknown/Multiple | Architecture: | Unknown/Multiple Type of failure: None/Unknown | Test Case: Blocked By: | Blocking: Related Tickets: | Differential Rev(s): Wiki Page: | -------------------------------------+------------------------------------- Comment (by Ben Gamari <ben@…>): In [changeset:"9b7eec8614f531e20a34e8dd2f62293ab0fedf8c/ghc" 9b7eec8/ghc]: {{{ #!CommitTicketReference repository="ghc" revision="9b7eec8614f531e20a34e8dd2f62293ab0fedf8c" tcExtendTyVarEnv2 changed to tcExtendNameTyVarEnv Reviewers: mpickering, goldfire, bgamari Reviewed By: mpickering Subscribers: goldfire, rwbarton, thomie, carter GHC Trac Issues: #15017 Differential Revision: https://phabricator.haskell.org/D4732 }}} -- Ticket URL: <http://ghc.haskell.org/trac/ghc/ticket/15017#comment:3> GHC <http://www.haskell.org/ghc/> The Glasgow Haskell Compiler
#15017: Come up with a better name for `tcExtendTyVarEnv2` -------------------------------------+------------------------------------- Reporter: mpickering | Owner: (none) Type: task | Status: closed Priority: normal | Milestone: 8.6.1 Component: Compiler | Version: 8.2.2 Resolution: fixed | Keywords: Operating System: Unknown/Multiple | Architecture: | Unknown/Multiple Type of failure: None/Unknown | Test Case: Blocked By: | Blocking: Related Tickets: | Differential Rev(s): Wiki Page: | -------------------------------------+------------------------------------- Changes (by bgamari): * status: new => closed * resolution: => fixed * milestone: 8.4.3 => 8.6.1 -- Ticket URL: <http://ghc.haskell.org/trac/ghc/ticket/15017#comment:4> GHC <http://www.haskell.org/ghc/> The Glasgow Haskell Compiler
participants (1)
-
GHC