22 Jan
2004
22 Jan
'04
9:46 a.m.
On Wed, 21 Jan 2004, Wolfgang Jeltsch wrote:
In addition, I would like as little undefinedness as possible, i.e., different implementations behaving as similar as possible. So I'd be happy if the handling of duplicate indices was defined by the library specification.
I agree (in this case at least), and in fact I'd like the semantics to be defined as array = accumArray (\a b -> b) _|_. Reasons: I think it's the most efficient to implement, and it would allow about half of my uses of accumArray to be replaced by array. (I think this is GHC's current behavior.) -- Ben