Perfectly sensible suggestion, but too late for the H98 Report, I'm afraid. It's time to freeze it. Simon | -----Original Message----- | From: D.Wakeling@exeter.ac.uk [mailto:D.Wakeling@exeter.ac.uk] | Sent: 08 January 2002 10:02 | To: haskell@haskell.org | Subject: (no subject) | | | | Hello, | | Is there any reason why the "gap" in a string literal is defined as | | gap -> \whitechar {whitechar}\ | | (in Section 2.6 of the report), rather than | | gap -> \whitespace\ | | ? The second, more liberal, definition of "gap" seems more | natural. Moreover, it would allow comments in the gaps, which | I would find useful. For example, | | classHeader :: String | classHeader = "\xca\xfe\xba\xbe\ -- magic number | \\x00\x03\ -- minor version | \\x00\x2d" -- major version | | David | -------------------------------------------------------------- | ----------------- | Dr. David Wakeling, School of Engineering and Computer Science | University of Exeter, Exeter, Devon, EX4 4PT. | unofficial web page: http://www.dcs.ex.ac.uk/~david | -------------------------------------------------------------- | ----------------- | | _______________________________________________ | Haskell mailing list | Haskell@haskell.org http://www.haskell.org/mailman/listinfo/haskell |