13 Jan
2004
13 Jan
'04
12:47 p.m.
Dear Haskellers, It is desirable to have shorter names for the data labels. Making a module out of a labeled data declaration does not look convenient. Providing the corresponding class operation is not always convenient. Maybe, future Haskell language could apprehend some special construct, like, say, in the following example data Foo1 = Foo1 {size :: Int ...} ... data Foo2 = Foo2 {size :: Int ...} ... f x y z = let size = Foo1..size in (size x) + (size y) + (Foo2..size z) ? "Foo.." is added when more than one type with the given label is visible in the scope. Copy, please, the answer to mechvel@botik.ru With kind regards, ----------------- Serge Mechveliani mechvel@botik.ru