Sebastian Setzer wrote on Thursday, 7 February, 2008 11:14:
Am Donnerstag, 7. Februar 2008 02:43 schrieb Twan van Laarhoven:
A bit of criticism concerning the name: According to the English Wikipedia, multiset is a single word. So the identifiers should be Multiset and IntMultiset instead of MultiSet and IntMultiSet. However, I think it would be even better to just use Bag and IntBag as identifiers. Those are shorter and maybe easier to remember. After all, the term bag is fairly standard.
For users of C++ STL, Multiset is probably easier to remember.
Off-topic: For further discussion of bag terminology, see EWD786a (http://www.cs.utexas.edu/~EWD/ewd07xx/EWD786a.PDF, transcript at http://www.cs.utexas.edu/~EWD/transcriptions/EWD07xx/EWD786a.html). Groetjes, <>< Marnix -- Marnix Klooster | Software Engineer, ERP LN Enterprise Server | Infor | (+31 or 0)342-428511 | marnix.klooster@infor.com | Infor Global Solutions (Barneveld) BV | P.O. box 143 | 3770 AC Barneveld | The Netherlands