4 Feb
2002
4 Feb
'02
9:11 a.m.
Hi Haskellers, personally, I'd prefer to use a kind of labeled fields notation at the point where the function is called, like: addBase{?base=7} 5 In recursive calls, this notation would then be optional, of course. If a function should be called multiple times with the same value of the implicit parameter, one could use a local definition: let addBase7 = addBase{?base=7} in addBase7 5 + addBase7 9 Cheers -- Christoph Herrmann