22 Apr
2014
22 Apr
'14
2:26 a.m.
On Mon, Apr 21, 2014 at 11:19 AM, Bardur Arantsson <spam@scientician.net> wrote:
On 2014-04-21 17:47, Edward Kmett wrote:
I, for one, could get behind just taking ifM, whenM, unlessM for these operations, proper naming conventions aside.
They've been independently reinvented in 60+ packages with these exact names.
If we do this, over time we'll save another 60+ packages the trouble of doing the same thing.
+1 (for the proposal, based on exactly the above summary)
+1 from me too, because I have the same functions with these names in my non-cabal packages. There might be a lot of non-cabal whenM etc. out there.