Those names suggest checks to see if something is a file or directory, not existence checks. Regarding the original question: I don't think this should be changed, because the current names aren't that bad, and changing them would break a lot of code. Erik On Wed, Jun 5, 2013 at 2:49 PM, Michael Snoyman <michael@snoyman.com> wrote:
I'm personally quite fond of system-fileio's naming scheme: isFile and isDirectory. Actually, I generally find system-fileio and system-filepath to be a great set of libraries for most file operations.
On Wed, Jun 5, 2013 at 3:41 PM, harry <voldermort@hotmail.com> wrote:
doesFileExist and doesDirectoryExist seem overly verbose - wouldn't fileExists and directoryExists be better?
Not a major issue, but easily fixed.
-- View this message in context: http://haskell.1045720.n5.nabble.com/doesFileExist-and-doesDirectoryExist-ov... Sent from the Haskell - Libraries mailing list archive at Nabble.com.
_______________________________________________ Libraries mailing list Libraries@haskell.org http://www.haskell.org/mailman/listinfo/libraries
_______________________________________________ Libraries mailing list Libraries@haskell.org http://www.haskell.org/mailman/listinfo/libraries