Alternatively, we could have it be `Proxy# a -> Int`, which should have identical performance characteristics to `Const Int a` but with the added benefit that it's a little easier to understand how it's supposed to be used. On Thu, Dec 14, 2017 at 12:37 AM, Zemyla <zemyla@gmail.com> wrote:
I honestly think we should make it a Const Int a, instead of a function, so that it's a number in the typeclass dictionary and not a function.
On Wed, Dec 13, 2017 at 10:41 PM, M Farkas-Dyck <strake888@gmail.com> wrote:
On 2017-12-13 08:19 PM, David Feuer wrote:
+1, but we should also do this for sizeOf and alignment in Foreign.Storable.
Yes, good idea
_______________________________________________ Libraries mailing list Libraries@haskell.org http://mail.haskell.org/cgi-bin/mailman/listinfo/libraries
Libraries mailing list Libraries@haskell.org http://mail.haskell.org/cgi-bin/mailman/listinfo/libraries
-- -Andrew Thaddeus Martin