Or "lookupSharedPointer", if that is the important part of the operational semantics. Regards, Malcolm (iPhone) On 27 Jun 2016, at 23:17, David Feuer <david.feuer@gmail.com> wrote: Another option might be "find".
On Jun 27, 2016 5:56 PM, "David Feuer" <david.feuer@gmail.com> wrote: As much as I dislike the names lookupGT, et al, I think that's probably your best bet now that they exist.
On Jun 27, 2016 5:52 PM, "Nicolas Godbout" <nicolas.godbout@gmail.com> wrote: David Feuer wrote:
+1 on the function. -1/2 on the name.
To be honest, I briefly considered the name `lookupEQ`. The name would fit nicely with `lookupGT` and company.
Nicolas.
_______________________________________________ Libraries mailing list Libraries@haskell.org http://mail.haskell.org/cgi-bin/mailman/listinfo/libraries