15 Aug
2008
15 Aug
'08
4:55 p.m.
On Fri, Aug 15, 2008 at 8:44 AM, Ross Paterson <ross@soi.city.ac.uk> wrote:
The Arrow class as originally defined by John Hughes had methods arr, >>> and first. (>>> has since been moved by #1773 to the Category class.) When writing the "Fun of Programming" paper, I added pure as a synonym for arr, because Richard Bird preferred it. However this name hasn't caught on, and now it clashes with a method in the Applicative class, so I propose to remove it.
I agree. Personally, I prefer 'pure' to 'arr' for arrows, and I wish we could have called the operation in Applicative something different, but it's too late for that. -- Dave Menendez <dave@zednenem.com> <http://www.eyrie.org/~zednenem/>