+1 for lookup. On 30.05.2016 04:48, Edward Kmett wrote:
Then again, most of Data.Sequence already clashes with the Prelude.
On Sun, May 29, 2016 at 10:47 PM, Edward Kmett <ekmett@gmail.com <mailto:ekmett@gmail.com>> wrote:
Oops. Prelude. No I guess it doesn't.
On Sun, May 29, 2016 at 9:40 PM, Edward Kmett <ekmett@gmail.com <mailto:ekmett@gmail.com>> wrote:
lookup works for me.
-Edward
On Sun, May 29, 2016 at 6:52 PM, David Feuer <david.feuer@gmail.com <mailto:david.feuer@gmail.com>> wrote:
I'm tempted to go with `lookup`, to match Data.IntMap.
On Sun, May 29, 2016 at 6:35 PM, Francesco Ariis <fa-ml@ariis.it <mailto:fa-ml@ariis.it>> wrote: > On Sun, May 29, 2016 at 06:28:25PM -0400, David Feuer wrote: >> I don't like that bikeshed color much either. Go ahead and suggest >> something else. > > safeIndex? totalIndex? Best solution would be to rename index to > unsafeIndex and your proposed function to index, but it's obviously > not practicable. > _______________________________________________ > Libraries mailing list > Libraries@haskell.org <mailto:Libraries@haskell.org> > http://mail.haskell.org/cgi-bin/mailman/listinfo/libraries _______________________________________________ Libraries mailing list Libraries@haskell.org <mailto:Libraries@haskell.org> http://mail.haskell.org/cgi-bin/mailman/listinfo/libraries
_______________________________________________ Libraries mailing list Libraries@haskell.org http://mail.haskell.org/cgi-bin/mailman/listinfo/libraries
-- Andreas Abel <>< Du bist der geliebte Mensch. Department of Computer Science and Engineering Chalmers and Gothenburg University, Sweden andreas.abel@gu.se http://www2.tcs.ifi.lmu.de/~abel/